Documentation

Hebrew Images

For a book containing Hebrew characters, the text may need to be replaced with images in order to display properly on all e-readers.

Prerequisites

If Hebrew has been typeset with Unicode characters, this method can be used to create consistent, high-quality images for use in the e-book. This method results in images that are cropped with a consistent amount of white space around the text and does not require the manual action of cutting images out of an existing PDF. The instructions are written for content that exists in InDesign source files, but it can apply to content that has not yet been typeset, and it can also be adapted for other languages, as needed.

Note: Though it will read from left-to-right, Hebrew text is correct as it appears within a text-only file. Programs like InDesign and some e-readers use settings to interpret this text properly to read from right to left.

Planning and Approach

Plan the Work

1. Assess

Confirm the source files have clearly identified the Hebrew content through the use of a style name or font.

2. Plan

If any elements are not WFDW-compliant, determine whether they need to be fixed in InDesign or if they can be addressed in the resulting .sam.

3. Act

Carry out the planned actions.

Working

1. Save Regularly

Save your files regularly as you work. Some of the adjustments throughout this process cannot be undone easily; saving ensures you can fix a problem or backtrack as needed.

2. Check Your Work

While working, check the resulting files against any existing source/reference files, such as the print PDF or original Word documents.

Procedure

Create JPEG Images

1. Export .sam from InDesign

Using Scribe Tools for InDesign, follow the procedure for exporting .xml from InDesign and processing to .sam through the Digital Hub.

2. Isolate and Review the Hebrew Text

Delete all of the text in the .sam file except for the Hebrew.

Each Hebrew word or phrase (the blocks to capture as images) should appear on its own line.

Confirm the content in the .sam file appears in the proper order. If Hebrew phrases broke over lines in the original typeset, some word order errors may occur.

3. Assign a Paragraph Style

Assign the p paragraph style to every line.

4. Process to IDTT

Process the .sam file to IDTT through the Digital Hub.

5. Flow into InDesign and Adjust Settings

Flow the IDTT file into InDesign.

Set the p paragraph to display the Hebrew language. Under Advanced Character Formats, set the language to Hebrew. Under Justification, set the composer to Adobe World-Ready Paragraph Composer.

Set the p paragraph style to force a new page. Under the paragraph style’s Keep Options, select Start Paragraph: On Next Page.

Set p paragraph style to be an appropriate point size. Often, this will be larger than what appeared in the original typeset.

Recommended default: SBL Hebrew font set at 30 pt.

6. Review the File

Check the Hebrew text against any source/reference files. Confirm that all characters display properly and appear in the correct order.

7. Output JPEG Images

Export the InDesign file to JPEG.

Select a resolution of 300 and a color space of RGB.

InDesign will number all images after the first. Add “1” to the end of the first image’s file name.

Recommended: Name your Hebrew image files with an indicator such as “heb” to differentiate these images from any others used for a given project (e.g., scr-project-heb01.jpg). Add leading zeros to file names so that all files are numbered consistently and sort in order.

Crop JPEG Images in Photoshop

1. Set up In/Out Folders

Set up In and Out folders, and place the individual Hebrew .jpg files in the In folder.

Recommended: Designate a location on your computer to keep these In and Out folders for use whenever needed.

2. Create a Photoshop Action

Go to Window > Actions.

Go to Create New Action, give the action a name (e.g. “heb-crop”) and Record.

If an Action has already been created, proceed to step 7.

3. Select Color Range: Shadows

Got to File > Open and open the first image.

Go to {~app-menu:Select > Color Range…]

In the top dropdown menu, choose Shadows. Check the Invert option. This will select all the white space outside of the characters.

4. Select Color Range: Inverse

Go to Select > Inverse. This will select the characters themselves.

5. Expand the Crop Area

Go to Select > Modify... > Expand and input 5 pixels. This will give the image some room on the edge.

6. Crop and Save

Go to Image > Crop, then Save As into your Out folder and Close.

Under Actions, stop the recording.

7. Run the Photoshop Batch on All Images

Go to File > Automate > Batch...

Select the action to run and choose the In folder for the Source location and the Out folder for the Destination.