Documentation

Sublime Text Setup

Instructions for setting up Sublime Text to meet Scribe requirements.

Sublime Text must be installed before the Scribe packages can be installed.

Package Control

Before installing any Scribe packages, the open source Package Control software must be enabled within Sublime. To begin, open the console using the Ctrl+~ keyboard shortcut or by going to View > Show Console.

Note: Sublime Text 2 is no longer supported. Installation instructions apply to Sublime Text 3 and Sublime Text 4. Mac users on MacOS Version 11.1 (Big Sur) or later who had previously used Sublime Text 2 will need to upgrade to Sublime Text 3 or later.

Instructions for Sublime Text 3 and 4

For use with Sublime Text 3 and 4 only, this will require you to restart Sublime Text.

Package Control for Sublime Text

Scribe Repository

With Package Control installed, configure it to recognize Scribe’s package repository.

Open the Command Pallet using the Ctrl+Shift+P/Command+Shift+P (for Windows/Linux and Mac, respectively) keyboard shortcut or by going to the Tools > Command Pallet menu item.

With this menu open, type Add Repository and click the item named Package Control: Add Repository.

A text-entry box will appear at the bottom of your Sublime Text window. Enter the following URL and hit [ENTER]:

https://gitlab.com/scribe-projects/sublime-repository/-/raw/master/repositories.json

Scribe Packages

Open the Command Pallet using the Ctrl+Shift+P/Command+Shift+P (for Windows/Linux and Mac, respectively) keyboard shortcut or by going to the Tools > Command Pallet menu item.

With this menu open, type Install Package and select the item named Package Control: Install Package.

The list of installable packages is then generated. This can take a few seconds.

Once a new listing has popped up in the Command Pallet, search for Scribe’s packages by typing scribenet. A list of the following packages will appear:

  • scribenet-sublime-encoding
  • scribenet-sublime-invisibles
  • scribenet-sublime-iterator
  • scribenet-sublime-keybindings
  • scribenet-sublime-regex-results
  • scribenet-sublime-settings
  • scribenet-sublime-validation

Install a package by selecting it with your mouse or navigating to one with your keyboard’s arrow keys, using the [ENTER] key to select it with your keyboard. Repeat this process for each Scribe package.

Troubleshooting

If you successfully added the Scribe Repository but were unable to find any scribenet packages, review the Package Control user settings. In Sublime, go to Preferences > Package Settings > Package Control > Settings. This should open two files side by side in a new window. The longer file controls the default settings and cannot be edited; the shorter file controls the user settings and can be modified.

Confirm that the following repository is listed in the user settings file.

	"repositories":
	[
		"https://gitlab.com/scribe-projects/sublime-repository/-/raw/master/repositories.json",
	],

If the lines are not included, confirm that you followed the steps listed under the previous Scribe Repository section. You can also copy the lines directly into the user settings file manually.

If the lines are included but you still cannot locate the scribenet packages, you may need to change the method Package Control uses to download . Some system configurations require the use of a different program to download the files. This can also be modified in the same user settings file. Add these lines to your user settings.

	"downloader_precedence":
	{
		"linux": [ "curl", "urllib", "wget" ],
		"osx": [ "curl", "urllib" ],
		"windows": [ "wininet" ]
	},

Proceed with the installation instructions at “Scribe Packages.”