Documentation

SAI Installation

SAI Software Requirements

The SAI works with the following versions of Word:

  • Word 2007 (PC)
  • Word 2010 (PC)
  • Word 2013 (PC)
  • Word 2016 (PC)
  • Word 2019 (PC)
  • Word 2011 (Mac)
  • Word 2016 (Mac)
  • Word 2019 (Mac)

Scribe’s goal is to keep the SAI up to date with the latest edition of Word in Office 365.

Download the SAI

  1. For simple organization, create an “SAI” folder on your computer so all SAI-related files can be saved in one place.
  2. In order for the SAI to work correctly, first download two additional necessary files. They can both be found in the scml-word-templates package. Download this zip file and extract its contents.
    • scr-scmllist.txt Copy this file to your SAI folder.
    • scr-word-template.dot Copy this file to your SAI folder.
  3. To download and install the SAI, go to Downloads. If you do not see a download for the SAI, you will need to log in to your Scribe account before proceeding. Download the SAI and save the zipped file in your SAI folder.

Install

  1. Unzip SAI-setup.zip, close Word if it is open, and then double-click SAI-setup.doc to open it in Word. You may be prompted to close any open documents.
  2. Enable macros if prompted.
  3. Fill in the registration information and review the terms. Select I Agree and click OK to send your registration to Scribe (requires an internet connection; a web browser will open, and your registration information will be passed to Scribe’s site).
  4. Word will close automatically. The next time you open Word, the SAI should be the second tab in your ribbon (after File). In Word 2011, the SAI will appear as a command bar at the top of the screen (and can be moved anywhere). If you are prompted to set the location of your scr-word-template or scmllist, click OK and do so. Some features will work without one or the other of these resource files, but the SAI may be slower. Some features will not work at all if neither resource is present.

See the Troubleshooting section below or consult the SAI-readme.txt file for troubleshooting help. This file is also available from within the SAI; click View Readme in the User Options section.

Installing Updates

New versions of the SAI may be installed in the same manner. The locations of the scr-word-template and scr-scmllist files will remain set from the initial installation.

Troubleshooting

I received the following error message: SAI template cannot be found. Ensure that the setup files have been unzipped and that the SAI.dotm file is in the same directory as the SAI-setup.doc file.

Check that the folder has been unzipped and that SAI-setup is opened from the resulting folder (not from within the ZIP file). The SAI.dotm file must not be moved out of the folder before attempting to run the installer.

I received a message on start-up regarding a prerequisite step for Microsoft Word Mac versions for 2016 or more recent indicating that I need to place the Applescript helper file manually.

  1. Navigate to /Users/[USERNAME]/Library in Finder. The easiest way to do this is by holding the Alt key while accessing Finder’s Go menu. Library will appear in the list of destinations while the Alt Key is pressed.
  2. Look for the folder “Application Scripts.” If you see “Application_Scripts” (underscore in place of space), rename it to “Application Scripts.” If you do not see the folder at all, create it.
  3. Within “Application Scripts,” find or create a folder called “com.microsoft.Word” (note the capitalization of “Word”).
  4. Copy the file “scrHelperAS.scpt” from the unzipped setup folder into “com.microsoft.Word.”
  5. Restart Word if necessary.
  6. This SCPT file is required for the SAI to function properly in Word 2016 for Mac.

The installer displayed an error message. I’m on a Mac and running Word 2016 or later.

If the installer crashed while you were attempting to run the installer, you may have to place the files manually:

  1. Move SAI.dotm into the following folder:

    /Users/[USERNAME]/Library/Group Containers/UBF8T346G9.Office/User Content.localized/Startup.localized/Word/

    (You may not see “.localized” when navigating to the folder in Finder.)

  2. Move scrHelperAS.scpt into the following folder:

    /Users/[USERNAME]/Library/Application Scripts/com.microsoft.Word/

  3. Restart Microsoft Word. The SAI should load after a few seconds.

The installer says that it completed successfully, but the SAI doesn’t appear in my ribbon.

If you do not see the SAI ribbon at all, do the following to ensure that there isn’t a local setting in place disabling add-ins:

PC Go to the File tab and select Options. Within Options, select Add-Ins and find the Manage drop-down menu. Select Word Add-Ins and click Go. In the dialog box that appears, select the Templates tab and look for SAI.dotm in the list of Global templates. If it is not checked, check it and click OK. This should cause the SAI ribbon to appear.

Mac Go to the Tools menu and select Templates and Add-Ins. In the dialog box that appears, select the Templates tab and look for SAI.dotm in the list of Global templates. If it is not checked, check it and click OK. This should cause the SAI ribbon to appear.

The SAI never loads when I start Microsoft Word. I’m on a Mac and running Word 2011.

If you would prefer the SAI opened at start-up, we have provided the following work-around. This requires making changes to the Normal template. Scribe strongly recommends backing up your existing Normal template before taking the following steps. Making changes to the Normal template can cause your existing settings to fail. Scribe provides no warranty for failures of the Normal template.

  1. Open Word. In the Tools Menu, choose Macro > Visual Basic Editor. This will open the Visual Basic Editor.
  2. Find the Project window. If you cannot see it, go to View > Project Explorer to bring it up.
  3. In the Project Explorer, right-click (command-click) on Normal (Normal.dotm). Select Import File. In the browse window that opens, locate the SAI-setup folder and choose LoadSAI.bas.

This will import a module into your Normal template that will attempt to open the SAI add-in at start-up. If you have existing AutoExec subroutines running, you may need to merge them.

Handling Error Reports

If an Error Report pops up while using the SAI, click OK to view the Error Log, which can be copied. When sending feedback to Scribe, please include the error log in your message.